Decorum for the Forum:
  • Be nice. If you want to be mean, try Reddit.
  • No Piracy. If you want to be a thief, there are dark places on the internet dedicated to that.
  • No Cracking. Discussions on AnyDVD, DeUHD, DVDFab, UHDKeys and similar tools are not permitted here.
  • No Spamming. If you want to make a buck, work smarter... somewhere else.
  • No Adult Content. Half the internet is dedicated to adult content. This half isn't.

Privacy Policy: Click Here to Review (updated September 30, 2020)

[Fixed in 4.2.2021.0203] 4.2 Problem

General support forum for Chameleon MediaCenter (formerly MM Browser)
Post Reply
dvoncannon
Posts: 28
Joined: Sun May 10, 2020 3:30 pm

[Fixed in 4.2.2021.0203] 4.2 Problem

Post by dvoncannon » Tue Feb 02, 2021 10:12 pm

Today I installed Version 4.2 of CMC. After install I ran an export with CME, started CMC to do a sync but was greeted with an almost blank screen showing only the settings gear and exit icon. There are two grey drop down arrows at the top of the screen that show a drop down list of streaming services. (See enclosed screen shot)
I have not been able to find a way back to the normal home screen. Is this an error or have I hit something and there's an easy way back?
Attachments
Screenshot of opening screen
Screenshot of opening screen
CMC 2221.png (484.72 KiB) Viewed 546 times

User avatar
Pauven
Posts: 2026
Joined: Tue Dec 26, 2017 10:28 pm
Location: Atlanta, GA, USA
Contact:

Re: 4.2 Problem

Post by Pauven » Wed Feb 03, 2021 8:53 am

I made a mistake in v4.2. I changed the format of the CMC.cfg file, and forgot to add backwards compatibility for the list of scanned Movie Library folders. After the upgrade, this list gets wiped out.

To fix, simply re-add your folders for scanning, then run another sync. The folder list is saved using the new file layout, so the issue won't come back.

This issue also cleared the list of any Music Library folders, if you were using that feature, so re-add those too if needed.

Interestingly, this mistake has given me some insight into who is still using CME. Users who have already switched over to using CCC were not affected.
President, Chameleon Consulting LLC
Author, Chameleon MediaCenter

User avatar
Pauven
Posts: 2026
Joined: Tue Dec 26, 2017 10:28 pm
Location: Atlanta, GA, USA
Contact:

Re: 4.2 Problem

Post by Pauven » Wed Feb 03, 2021 12:18 pm

I have just published v4.2.2021.0203 which includes a fix for this issue. Unfortunately, it will only help those who have not yet upgraded to v4.2. Since you've already upgraded to v4.2, you'll have to manually re-add the Movie / Music folders.

Also, I noticed from your screenshot that it looks like the navigation is broken since no Icon is highlighted. If this is the case, you can use a mouse/touch to select the top-left Settings icon so you can apply the fix. Worst case, if that doesn't work, you should delete your CMC_MovieDB.bin, CMC_MovieDB.xml, and CMC_SmartSync.bin files, which should allow CMC to start up in a workable configuration.

Sorry for the trouble this has caused.

Paul
President, Chameleon Consulting LLC
Author, Chameleon MediaCenter

dvoncannon
Posts: 28
Joined: Sun May 10, 2020 3:30 pm

Re: [Fixed in 4.2.2021.0203] 4.2 Problem

Post by dvoncannon » Wed Feb 03, 2021 4:49 pm

Reentering the folders to scan resolved this problem. Thank you

Post Reply